rejetto forum

Software => HFS ~ HTTP File Server => Topic started by: jake59 on December 13, 2007, 05:32:18 PM

Title: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: jake59 on December 13, 2007, 05:32:18 PM
I had a problem with IE 6 and having to hit refresh to be able to see the HFS webpages.

If you use HFS and go to any of the transfer screens and instead you get a blank white screen, the problem may be the coding in the html template.

I tried different templates until I ran into the grey one. It loaded everytime without error. The main difference was the below line. Just replace this line in the default template

 <meta http-equiv="content-type" content="text/html; charset=UTF-8" />

with this line

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: TSG on December 13, 2007, 10:00:12 PM
Thats Western character encoding and will only work for English style character sites.

UTF-8 Unicode, is universal.

IE 6 supports UTF-8, i have no problems loading UTF-8 pages here in IE 6, Firefox and Opera.

Please don't tell me you use IE 6 as your main browser  :-\

I wouldn't say this is historical...
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: jake59 on December 13, 2007, 10:43:23 PM
IE 6 is what most of my customers use so that is what I must use.

It was meant to be historical in the sense to not delete it. I did not see any other post on the subject and many other people must run into the same problem since I have seven computers here and all of them use IE 6 and they all had the same problem.
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: rejetto on December 14, 2007, 10:03:14 AM
yes, several other people in the italian board pointed at this problem.
it's in my to-do-list.
sadly, the solution you suggest is not acceptable. HFS would stop working for a lot of non-western users. I will have to study the problem.
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: jake59 on December 14, 2007, 11:29:04 AM
It was meant only for people with the problem, not as a default setting in the program.

Maybe you could have the program read the browser character set when it starts and act accordingly, or as a toggle in the program options.
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: Foggy on December 14, 2007, 08:07:53 PM
Maybe a use for another macro.  :D
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: rejetto on December 17, 2007, 09:32:54 AM
is anyone having this problem with IE7 or Firefox or Opera ?
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: TSG on December 17, 2007, 10:09:30 AM
No, i have never experienced this problem because of the character set. In any browser.
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: Unknown8063 on December 17, 2007, 11:41:00 AM
is anyone having this problem with IE7 or Firefox or Opera ?

Nope, I don't recall ever encountering this issue with any browser.
Title: Re: Historical Post - IE problem where refresh has to be hit to see HFS webpage.
Post by: Guest on December 30, 2007, 12:31:01 PM
I too, see this problem. Default template wouldn't load at all
untill I clicked refresh for each page change.
My template would load, but not a empty folder, untill I
clicked refresh. I noticed the address bar didn't show the
empty folder untill refresh. Changing the charset=UTF-8 to
something else solved both templates here. I know ie6 is
pretty substandard, but its also still widely used.