rejetto forum

Software => HFS ~ HTTP File Server => Topic started by: Tuskenraider on September 23, 2007, 09:08:51 PM

Title: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 23, 2007, 09:08:51 PM
modified
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Foggy on September 23, 2007, 09:28:10 PM
certainly very strange, but I dont understand how to reproduce it
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 23, 2007, 09:37:21 PM
certainly very strange, but I dont understand how to reproduce it

http://yourip.ip.ip.ip//cacti/  notice the Two // before cacti?  thats the key...  www.ip.ip.ip.ip/cacti/ gives you a page not found but //cacti causes it to go all screwy.... btw im using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 23, 2007, 10:06:05 PM
since my first post i have noticed that you dont even need the word "cacti"  all you need is www.yourwebsite/ipaddy.com// with two // at the end... and you get a constant repeat in the address bar..

thanks for reading and pondering

tuskenraider

p.s i have locked down my hfs server (need a username and password to use it) if anyone wants to run tests please let me know and ill set you up an account... thanks

tuskenraider
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Foggy on September 23, 2007, 10:54:25 PM
I couldnt reproduce it by going to http://localhost// with Firefox 2.0.0.7
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: maverick on September 23, 2007, 11:50:36 PM

I tried a few addresses here and couldn't reproduce it either. 
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Foggy on September 24, 2007, 12:12:00 AM
maybe it has to do with a combination of things such as default file mask, virtual folders.. etc etc
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: TSG on September 24, 2007, 02:58:10 AM
I cannot reproduce this bug. At all.
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 24, 2007, 07:10:58 AM
idk man... maybe its just me....  but it the whole repeating subfolder thing in both ie6 and firefox...  could just be the way i have it set up... idk.... is there any information anyone would like???  anything i have left out?? i will upload anything i need to upload so you all can see what im talking about. heck ill take off the username and password for my site if you all would like so you may try it on my hfs. just let me know..

tuskenraider
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 24, 2007, 07:28:13 AM
rejetto check your inbox.
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: mike on September 24, 2007, 07:29:51 AM
Why don't you just run more than one instance of HFS.  One for each of your sites.  Different ports of course.  Forget about that re-directing as I'm sure you can tell by now that it isn't working.
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 24, 2007, 08:08:08 AM
Why don't you just run more than one instance of HFS.  One for each of your sites.  Different ports of course.  Forget about that re-directing as I'm sure you can tell by now that it isn't working.

i guess i can eliminate the auto redirect page.... i like to have subfolders... and to be honest i have been using hfs for a year now (yeah im newish) and this is the first "issue" or oddity i have stumbled across...  but ill look into eliminating the redirect page..  the two port thing just gets complicated with dyndns... and port forwarding... so if "it aint broke dont fix it"

thanks for reading and pondering.

tuskenraider..
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 24, 2007, 10:57:26 AM
I couldnt reproduce it by going to http://localhost// with Firefox 2.0.0.7

i was able to reproduce the "anomaly" with local host. after i changed the auto redirect.  idk what the deal is... anyone have any ideas?

tuskenraider

p.s i added a screen shot of my hfs.. if anyone has anyideas
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 24, 2007, 11:45:44 AM
maybe it has to do with a combination of things such as default file mask, virtual folders.. etc etc

it is the default file mask. removed the index.htm (file) tried the // problem..  didnt happen.  replaced the index.htm (file) again it happend..  removed the default file mask... which was index.htm again the // problem was gone.   replaced the default file mask. and again the // problem occurred.  so.. foggy your right.. it is an issue with default file mask. 

tuskenraider

edit.. i thought perhaps since i had a index.htm in the main aguyincookeville subfolder (www.aguyincookeville.com/aguyincookeville/index.htm) i went and renamed that index.htm to main.htm so it was (aguyincookeville.com/aguyincookeville/main.htm) tried the // issue. and still got the repeating error.. this is what i got. http://www.aguyincookeville.com//aguyincookeville/aguyincookeville/aguyincookeville/aguyincookeville/aguyincookeville/main.htm in the address bar so... any ideas?
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: rejetto on September 24, 2007, 01:11:13 PM
bug fixed in next build
Title: Re: http://ip.ip.ip.ip/cacti/?
Post by: Tuskenraider on September 24, 2007, 01:12:47 PM
bug fixed in next build

bless you sir!!!!  ill dance at your wedding!!!!  lol

tuskenraider