Recent Posts

Pages: [1] 2 3 ... 10
1
Bug reports / Re: httpauth challenge HTTP headers - bug
« Last post by rejetto on November 19, 2017, 05:05:02 PM »
hi delmote, thanks for your contribution.
I've now spent some minutes investigating this but i need some more time before saying something.
I'll keep you posted.
2
HFS ~ HTTP File Server / Re: Log encoding and multiply files upload problems
« Last post by rejetto on November 19, 2017, 04:28:32 PM »
Hello. Thank for HFS! It is really good and very powerfiull software.

welcome, and sorry for the late reply

Quote
1) Please let me know, where can I set log encoding? In my current configuration of HFS I write log (upload / download actions with timestamps) in file, but russians symbols of real folder are abracadabra in log.

sadly HFS doesn't currently support unicode. Some problems can occur because of this.
There's no option about log encoding.

Quote
2) And the second question about multiply upload files to HFS. Sometimes (not every time) I receive "connection reset error" in

i've already heard of network problems with Wine, but I can only suggest to report to Wine's team.
3
HFS ~ HTTP File Server / Re: Log encoding and multiply files upload problems
« Last post by bmartino1 on November 15, 2017, 10:40:13 PM »
sorry about gramer / spelling / etc, only have tonight to do this :p ip changes to much to log on forum outside from home
only had 30 min o respond :p :( good luck, hope this works for you
================

i recommend using the most updated version of wine. Since you installed wine 1.8, that the version you will be using(wine tricks will install wine - DON"T INSTAL A SPECIFIC WINE VERSION, UNLESS YOU KNOW WHAT YOUR DOING!).(... this is why winetricks was created!)... Wine has since released other updates (2.4 is curent atm).

Unfortunatley
My current work has me travel and access to the forum and the vm test bed is not fesiable (until after the holidays/my curent work schedule...).

YOU WILL HAVE TO REINSTALL WINE AND the SOFTWARE!

it is clear that there is miss under standing to my instruction form the other post.

so i will give you the lines one by one that you must run to get a good working version.

first we are purgeing hte system of wine(complety uninstall and removing all wine related files.
(this is due to 1. I don't know what config chages or wine realted problems that could be casueing the issue. 2. Guratee taht if you run these comands it will run HFS as if it was with your other VM)

***(make sure to copy the exact commands in this order):

Open mate terminal

become super user root via comand
Code: [Select]
sudo su
Code: [Select]
sudo apt-get remove --purge wine\*
Code: [Select]
sudo apt-get --purge remove wine

Close and restart the PC VM.

now open a standard user mate termainl (not SU)
(this is to remove the wine directiores form your curent user, this will also have to be done at the root level "SU")

Code: [Select]
rm -r "$HOME/.wine"
rm  $HOME/.config/menus/applications-merged/wine*
rm -r "$HOME/.local/share/applications/wine"
rm $HOME/.local/share/desktop-directories/wine*
rm $HOME/.local/share/icons/????_*.xpm

IF you used the wine config and chaged location, you will have to remove that folder....

once again we will log into super user root:

Code: [Select]
sudo su

Code: [Select]
rm -r "$HOME/.wine"
rm  $HOME/.config/menus/applications-merged/wine*
rm -r "$HOME/.local/share/applications/wine"
rm $HOME/.local/share/desktop-directories/wine*
rm $HOME/.local/share/icons/????_*.xpm


Now we clean up the ubuntu packages to make sure we are geting the lates and a clean version...

Code: [Select]
sudo apt-get update
Code: [Select]
sudo apt-get autoclean
Code: [Select]
sudo apt-get clean
Code: [Select]
sudo apt-get autoremove
----------------------------------

At this point wine and everything wine related will be gone.

You stated that you are runnig a 32bit editon of ubuntu mate:

if you are runing a 64 bit addition, you will have to add the arc type to run 32 bit application:
Code: [Select]
sudo dpkg --add-architecture i386
*I recommend ruining this command to verify that you are, or have a i386 (pc x86 OS) architec.

and run the update procedures

Code: [Select]
sudo apt-get update
Code: [Select]
sudo apt-get upgrade
-------------------------------------------
*EVERYTHING SHOULD BE RUN VIA ROOT AT THIS MOMENT...
At this point all available ubuntu updates and packages are ready

so we will start with the required packages first
*due to issues form ubuntu 7, and a bunch of wine updates, wine itself no longer instals theses optional packages, but will grab the dependents only to run there package. These commands will grab the other packages and will be required to install winetrick, with will install wine.

first we insall the wine development pacakges:
Code: [Select]
sudo apt-get install --install-recommends winehq-develthen we insatll the stage for wine itslef
Code: [Select]
sudo apt-get install --install-recommends wine-stagingFinaly we insall the most uptodate verion of wine:
Code: [Select]
sudo apt-get install winehq-staging
The ordering and one by one line install is important here to not make a conflict.
when done, the packages will complain that you will not need the wine-hq devel, and one other deveopment package.
*everythign to run a wine (windows emulated state) will be installed at this point

all of witch can be found at the wine hq website:
https://wiki.winehq.org/Ubuntu

------------------------------
finaly we build wine via winetricks:
Code: [Select]
sudo apt-get install winetricks
before we run wine tricks, we want to install some wine reequirments

install the netframe work! "mono"
Code: [Select]
sudo apt-get install mono-vbnc
install gecko (this will help HFS ALOT!)
https://wiki.winehq.org/Gecko
Code: [Select]
sudo apt-get install wine-gecko
these are some barebones requirments to most windoes based programs.
geko emualtes info that was internet explore, and helps in dealing with windows side tcp transaction. withc help hfs on a linux build
....

-------------------
at this moment, with out specify a wine version, wine is installed, and needs to be configure


open winetricks (either via standard user termainl non root) or via the aplication menu

install mon, geko, (esentialy say yes to all the popup)

-------------------------------

now downlaod HFS and tryi your test again.

I'm willing to bet its a wine issue, there are some many way to install an application and wine is very fickle these days.

HFS as stated via rejeto was orginaly created for windows xp, so i recomend a wine configuration for winodws xp, but i have found that win 7 and below work fine.
4
Bug reports / httpauth challenge HTTP headers - bug
« Last post by delmote on November 15, 2017, 01:00:32 PM »
The HTTP headers sent by HFS when issuing a httpauth challenge (HTTP 401 Unauthorized) do not contain a "Content-Length" header.  This causes unpredictable behavior, and sometimes data corruption, in different clients.

For example, in Firefox, when visiting a password-protected HFS URL, the browser immediately prompts the user for the username and password, which is the expected behavior.  But then, Firefox does not send the user's username+password to HFS because Firefox was not able to decide if or when the end of the HTTP 401 response arrived.  So Firefox waits forever, until HFS times out and closes the TCP connection.  Only after the TCP connection is dropped by HFS does Firefox know the 401 response body is finished, at which point it re-connects and sends its second GET with httpauth info.  The result of all this is that the user experiences a long delay (over a minute sometimes) after entering his user/pass.

Another example: wget emulates browsers when making an httpauth request by first sending a "dummy" GET without httpauth followed as soon as possible by a second GET with httpauth.  Unlike Firefox, however, wget does not wait forever after the first (401) server response if that response contains no Content-Length HTTP header.  Instead, wget tries to guess when the 401 response has been fully sent by watching for a pause in the I/O flow from the server.  (It does this as an "imperfect solution" to servers that send no Content-Length HTTP header in their 401 responses.)  Well, unfortunately, if coincidental internet lag occurs during this 401 reply, wget's guessing mechanism is triggered too early, and wget sends its second (httpauth'ed) GET before the full 401 reply body has been received.  As a result, some or all of the 401 reply's body gets prepended to the output file by wget.  Let me make all this clear with screenshots:
https://i.imgur.com/e9edjSD.png  <-- wget sending second GET too early due to an internet lag (packet sniffer)
https://i.imgur.com/iXvLg8b.png   <-- how wget looks at command prompt (note "no headers, assuming HTTP/0.9")
https://i.imgur.com/UNDLA4V.png  <-- what wget wrote to the output file (HTTP 401's response body + actual mp4 file contents)

And yet other clients misbehave in yet other ways due to the lack of Content-Length.  Etc., etc., etc.

To fix all these issues, HFS simply needs to send a Content-Length header in the HTTP headers of its 401 responses.

If for some reason HFS cannot predict the length of its 401 responses (and therefore cannot insert a Content-Length header), then there is another way to solve this bug:

1.  When HFS sends a 401 response with HTTP/1.1, HFS can send the response with "chunked" transfer encoding
2.  When HFS sends a 401 response with HTTP/1.0 (where "chunked" transfer encoding is not allowed), HFS can instead insert a "Connection: close" HTTP header in its 401 reply's HTTP headers (regardless of what the client requested), and then immediately close the TCP connection at the end of the 401 response body.

If sending "chunked" would be impossible too, then it would also be fine to simply #2 (for HTTP/1.0 replies) on HTTP/1.1 replies as well.

Anyway, thank you so much for writing HFS.  It is amazing!
5
Programmers corner / Re: code on GitHub
« Last post by Rapid on November 15, 2017, 04:34:49 AM »
Nice work! :) I see you added Unicode support by compiling HFS using the latest Delphi, plus adding initial support to IPv6.

It would be nice if you publish a compiled .exe in your Github's releases section, so anyone could test and use your builds.
https://github.com/drapid/HFS/releases/tag/2.3k
6
HFS ~ HTTP File Server / Re: Log encoding and multiply files upload problems
« Last post by Mar on November 14, 2017, 10:48:39 AM »
bmartino1, thank you for your help and advise.
I tried to execute your instructions, but received the same error wiht multiply upload files.
There is my step by step installation:
1) on vmware hypervisor 5.5 I created two new vm's (for mate-ubuntu and for win7);
2) on the first vm, I installed 32 bit mate-ubuntu using link from your post. After that I updated OS:
Code: [Select]
apt-get update, apt-get uprgade and apt-get upgrade-dist commands. Later I added wine repo, instllaed it:
Code: [Select]
add-apt-repository ppa:ubuntu-wine/ppa, apt-get update and apt-get install wine1.8 and instlled winetricks (
Code: [Select]
apt-get install winetricks). After that I run winecfg and configured wineprefix for winxp. Downloaded the latest version of HFS, run it, tried to upload and received "connections reset" error.
3) on the second vm and installed Win7 home adv. (64 bit version). Run the latest version of HFS and multiply upload about 3GB without any errors (12-14 zip-files at once).

Please let me know if my ubuntu instllation are wrong. Could your test multiply upload in ubuntu-mate on your side?

Thank you. Regards, Mar.
7
HFS ~ HTTP File Server / Re: Mobile friendly website
« Last post by dj on November 14, 2017, 12:08:39 AM »
8
HFS ~ HTTP File Server / Re: Mobile friendly website
« Last post by bmartino1 on November 13, 2017, 09:45:24 PM »
you may have to add a custom user template file such as live rarw etc...

http://www.rejetto.com/forum/html-templates/

I'm aware of some  users making and having a mobile friendly version...

for example one built for the iphone:
http://www.rejetto.com/forum/html-templates/mobile-template/

then there is custum eding html and adding teh required hfs macro section to html pages to manulay creat a mobile friendly version
http://www.rejetto.com/forum/html-templates/multiple-templates-based-on-browser/15/

Most html code there own and use hfs default tempalte as a base

Id redirect you to the wiki:
http://www.rejetto.com/wiki/index.php?title=HFS:_Template

*** it used to be easier to edit hfs template via another program:
http://www.rejetto.com/forum/html-templates/hfs-template-builder/
http://www.rejetto.com/forum/html-templates/hfs-template-editor/
***

dj created : mobile lite template with pic:
http://www.rejetto.com/forum/html-templates/responsive-small-screen-template/?action=dlattach;attach=8270
9
HFS ~ HTTP File Server / Re: Log encoding and multiply files upload problems
« Last post by bmartino1 on November 13, 2017, 09:34:25 PM »
hello, and welcome to the form.

For starters, i'm not sure about either of you questions. nor have a good answer for them.

It appears you are using ubuntu / a linux variety to run wine

http://www.rejetto.com/forum/hfs-~-http-file-server/login-sometimes-error-while-using-hfs-in-wine-ubuntu-help-me/msg1061701/#msg1061701

I would have you re-advise the setup to make sure wine is properly installed to run hfs native-ly.
-This may fix your second (2.) question...

as the the first, i'm not aware of changing the log texts encoding. I'm sure it is possible(leo might have more/better info) as this may pretain more to the language via file translation conversion stuff.
10
HFS ~ HTTP File Server / Mobile friendly website
« Last post by rokas2491 on November 13, 2017, 04:00:41 PM »
Hi, I published a small website by adding code to txt and publishing through HFS. But it turns that ''website '' is not mobile friendly. Even if code made so it should be, and I tested through other softwares and it worked. So is there anything I could do?
And I know HFS is not made for hosting websites.
Webpage:
http://80.213.60.171:12/puslapismusikk.html
Thank You
Pages: [1] 2 3 ... 10